Skip to content

[GHSA-5v8v-66v8-mwm7] Integer overflow in the bundled Brotli C library - #10804

Open
illia-v wants to merge 1 commit into
illia-v/advisory-improvement-10804from
illia-v-GHSA-5v8v-66v8-mwm7
Open

illia-v wants to merge 1 commit into
illia-v/advisory-improvement-10804from
illia-v-GHSA-5v8v-66v8-mwm7

Conversation

@illia-v

@illia-v illia-v commented Oct 30, 2026

Copy link
Copy Markdown

Updates

  • Affected products
  • CVSS v3

Comments
brotlicffi 1.0.9.0 was the first release to bundle an unaffected Brotli C library.
brotlipy was archived on PyPI. Its latest release 0.7.0 bundled the affected Brotli version 0.6.0.

Copilot AI auto review requested due to automatic review settings October 30, 2026 21:54
@github-actions
github-actions Bot changed the base branch from main to illia-v/advisory-improvement-10804 October 30, 2026 21:54
Comment on lines 11 to 16
"severity": [
{
"type": "CVSS_V3",
"score": "CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:L/A:L"
},
{
"type": "CVSS_V4",
"score": "CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N"
}
],

Copy link
Copy Markdown
Author

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

https://github.com/advisories/GHSA-5v8v-66v8-mwm7/improve kept just one CVSS, that wasn't my intent.

Copilot AI left a comment

Copy link
Copy Markdown
Contributor

Choose a reason for hiding this comment

The reason will be displayed to describe this comment to others. Learn more.

🟡 Changes recommended

Removing the existing CVSS v3.1 vector leaves only CVSS v4 data, preventing consumers that rely on CVSS v3 from obtaining the advisory’s severity score.

1 open issue
What changed in this PR

Updates the Brotli vulnerability advisory to cover two additional Python packages and revise severity metadata.

Changes:

  • Adds brotlicffi versions before 1.0.9.0 and brotlipy versions through 0.7.0 as affected.
  • Removes the CVSS v3.1 vector while retaining CVSS v4, and updates the modification timestamp.
File Description
advisories/​github-reviewed/​2022/​05/​GHSA-5v8v-66v8-mwm7/​GHSA-5v8v-66v8-mwm7.json Adds affected PyPI package ranges and revises severity and modification metadata.

Review effort: Max (auto)

],
"summary": "Integer overflow in the bundled Brotli C library",
"details": "A buffer overflow exists in the Brotli library versions prior to 1.0.8 where an attacker controlling the input length of a \"one-shot\" decompression request to a script can trigger a crash, which happens when copying over chunks of data larger than 2 GiB. It is recommended to update your Brotli library to 1.0.8 or later. If one cannot update, we recommend to use the \"streaming\" API as opposed to the \"one-shot\" API, and impose chunk size limits.",
"severity": [
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

2 participants